college-bot-v2/requirements.txt
Nexus 3d3487cedd
Update requirements
* Pin py-cord to a specific commit (so that this can be re-used long after I stop maintaining it)
* Update pillow to 10.3 (from 10.2)
* Remove requirement for psycopg
* Bump httpx to 0.27 (from 0.26)
* Bump selenium from 4.16 to 4.21
* Bump dnspython from 2.4 to 2.6
* Remove (explicit) dependency on aiosqlite (pulled in by tortoise anyway)
* Bump FastAPI from 109 to 111
* Bump Uvicorn from 0.26 to 0.30
* Bump Pydantic from 2.5 (to 2.7)
* Remove humanize dependency
* Bump lxml from 5.1 to 5.2
* Bump matplotlib from 3.8 to 3.9
* Add tortoise-orm dependency
2024-06-09 01:33:33 +01:00

23 lines
481 B
Plaintext

jishaku~=2.5
wheel>=0.42
setuptools>=69
yt-dlp @ https://github.com/yt-dlp/yt-dlp/archive/master.tar.gz
py-cord @ git+https://github.com/Pycord-Development/pycord.git@61cc544abdc0463c3e3fe866b12bda6a2064333c
httpx[http2]~=0.27
pillow~=10.3
selenium~=4.21
rich~=13.7
dnspython~=2.6
fastapi~=0.111
uvicorn~=0.30
psutil~=5.9
pydantic~=2.7
redis~=5.0
beautifulsoup4~=4.12
lxml~=5.2
matplotlib~=3.9
python-magic~=0.4
aiofiles~=23.2
fuzzywuzzy[speedup]~=0.18
tortoise-orm[asyncpg]~=0.21